Jeg havde et par ældre ubuntu 7.10 servere, der nu er EOL (End Of Life). Det opdager man ved at den ikke kan finde sit repository når man forsøger at lave en apt-get update, eller det var ihvertfald den måde jeg opdagede det på.

Heldigvis kan man (selvom distributionen er udløbet) få lov at køre en “do-release-upgrade”. Begge mine maskiner hvade dette program installeret i forvejen, jeg kan forestille mig at man ender ud i et godt gammeldags “dependency hell” hvis man skal til at installere manuelt, man kan jo ikke nå sit repository!

Nå, men den ene maskine kørte problemfrit igennem og alt var fryd og gammen. den opgraderer til 8.04LTS som først udløber i 2013 hvis man har server versionen  https://wiki.ubuntu.com/Releases så har man da lidt tid at løbe på 🙂

Men det var jo kun den ene, den anden var lidt mere genstridig. Når man kører kommandoen bliver man efter et stykke tid spurgt om man vil fortsætte, eller se detaljer for hvilke pakker der opgraderes, udskiftes og slettes, man skal trykke [yN] for yes eller no eller [d] for detaljer.

Jeg trykker selvfølgelig y da jeg vil fortsætte, men der sker intet, jeg trykker så “n” og den afbryder, jeg starter forfra og det samme gentager sig? Jeg prøver at trykke “d” den viser detaljerne? Hvad sker der, jeg banker hårdt i alle taster og får ramt “j”. Ahr den kører med dansk sprog og der skal trykkes “j” for ja selvom den skriver y. Nu kører den det hele igennem som det skal og begge mine systemer er opdaterede til 8.04 LTS.

0 Comments

Leave a Reply

Your email address will not be published.

Are you human? * Time limit is exhausted. Please reload CAPTCHA.

This site uses Akismet to reduce spam. Learn how your comment data is processed.